[bd] Attachment Store [Paid] 1.3.0

Store attachment differently and more effectively.

  1. xfrocks

    xfrocks XenForo rocks! Staff Member

    Bạn chuyển option về default rồi chạy move tool là được nhé.
     
  2. xfrocks

    xfrocks XenForo rocks! Staff Member

    Sorry for the late response, how is it working now? I guess there might be issue with the bucket policy.
     
  3. xfrocks

    xfrocks XenForo rocks! Staff Member

    Ah, that is nice. I didn't know about this feature. And it looks like we need to use Amazon SDK to take advantage of it which the current structure does not allow. We may revisit this again on our XF2 rewrite.

    Yes, it's a problem we inherited from the way XenForo generate thumbnail. There is no plan to address this for now though :(
     
  4. TheComputerGuy

    TheComputerGuy Webmaster

    Is there anyway to force SSL compliance?

    In the media addon from xenforo, the S3 bucket doesn't show the ssl version of the site. I told the addon to only use the https version of the attachments.
     
    Last edited: Mar 21, 2017
  5. RoldanLT

    RoldanLT Active Member

    What does this rebuild option exactly do?
     
  6. xfrocks

    xfrocks XenForo rocks! Staff Member

    It move files from their storage to the one configured in AdminCP > Options > Attachments.
     
    RoldanLT likes this.
  7. RoldanLT

    RoldanLT Active Member

    Move, so nothing will be left on internal_data folder?
    I just did the rebuild (using /data/ folder), so I can't uninstall this addon or else old attachments will not work?
     
  8. xfrocks

    xfrocks XenForo rocks! Staff Member

    Moving will free your hard drive but you can always run the move again to have them back in default locations.
     
    RoldanLT likes this.
  9. RoldanLT

    RoldanLT Active Member

    Nice, very solid addon (y).
     
  10. hoangnamdoan33

    hoangnamdoan33 New Member

    Nếu có thêm dropbox thì hay quá anh ơi
     
  11. TheComputerGuy

    TheComputerGuy Webmaster

    Is anyone using the AMS from xenaddons? The images aren't loading although they are on the AWS, and work correctly....
     
  12. Semper Fidelis

    Semper Fidelis New Member

    I was having a similar problem when I was trying to use a custom URL instead of just the S3 bucket URL.
     
  13. TheComputerGuy

    TheComputerGuy Webmaster

    Thank you for the reply, I'm not using a custom URL, just domain.aws... when I look at the source the aws URL shows.
     
  14. Semper Fidelis

    Semper Fidelis New Member

    When you right click on the source URL on your forum is the URL your S3 object URL? In other words, do you see one of those broken image pictures and can you right click on it and get the URL and it points to the actual s3 object? If so, is it possible that you have not set the bucket permissions properly?
     
  15. thienbui

    thienbui Member

    How to fix ?

    Thanks
     

    Attached Files:

  16. cjwinternet

    cjwinternet Webmaster

    We've nearly reached the file number limit on our CDN. Can we stop the importer and enter new details for a new CDN?
     
    Last edited: Jul 15, 2017
  17. cjwinternet

    cjwinternet Webmaster

    If a second ftp server was used, files will be be served from the new and old ftp servers. What about a subsequent cache rebuild? Would it do this one server at a time depending on which one it had the details for at the time?
     
  18. Fred.

    Fred. Webmaster

    Hi xfrocks,

    I also like to switch to the Frankfurt region.
    Even if you have "Keep Local Copy" enabled you have to go back to default?

    I also have to use new credentials because the old ones are not compatible.
     
  19. alfa1

    alfa1 Webmaster

    This would be nice.
     
  20. alfa1

    alfa1 Webmaster

    Since turning this on some thumb images do not display. This happens today in XFMG and AMS. Rebuilding thumbs doesn't help.
    I am running:
    - attachment improvements
    - lazy load images
    both by Xon.
     
Loading...