[bd] Social Share [Paid] 2.3.0

XenForo gets social.

  1. tohaitrieu

    tohaitrieu New Member

    I think i use Xenporta 2 and in Article View, i have not that menu. But in thread view, i can see the Publish Instant Article menu but have more error.
     
  2. xfrocks

    xfrocks XenForo rocks! Staff Member

    That makes sense. So what's the error?
     
  3. tohaitrieu

    tohaitrieu New Member

    Have so much br tag in content and couldn't publish to instant article.

    Suggest: Option for insert Ad Placement from Facebook Audience Network.
     
  4. xfrocks

    xfrocks XenForo rocks! Staff Member

    It depends on your content, but normally the html output comes straight from bb code formatter so it shouldn't have "too many" break. Do you have an example?
     
  5. tohaitrieu

    tohaitrieu New Member

    Example: I have an poem in my post. And have an line break for short sentence with br tag. --> It not convert from br tag to p tag as long sentence. Xenforo use br tag to break the line.
     
  6. xfrocks

    xfrocks XenForo rocks! Staff Member

    Can you post the bb code of that post and the output for Instant Article?
     
  7. anto74

    anto74 Member

    I have problem. The tread sharing to FB works only for admin but not for registered users. The permission are OK
    When user check post to Facebook In thread reply the page refresh and is unchecked.
    Thanks
     
  8. anto74

    anto74 Member

    Then problem is also in your site, here.
     
  9. xfrocks

    xfrocks XenForo rocks! Staff Member

    It's likely because of a permission problem with your connected Facebook account. In that situation, there will be a notice at the top of every page which asks you to authenticate any missing permissions. Do you see it here?
     
  10. anto74

    anto74 Member

    No, the page loaded when I click to Facebook? box disappear and is not loaded. In my site the same...only for admin user works
     
  11. RoldanLT

    RoldanLT Active Member

    All of a sudden, without any settings changed for several months I got this error now.
    Code:
    Server Error
    
    Abraham\TwitterOAuth\TwitterOAuth->oauth() in bdSocialShare/Helper/Twitter.php at line 127
    TwitterOAuth->getRequestToken() in bdSocialShare/Helper/Twitter.php at line 32
    bdSocialShare_Helper_Twitter::getAuthorizeUri() in bdSocialShare/XenForo/ControllerAdmin/Tools.php at line 148
    bdSocialShare_XenForo_ControllerAdmin_Tools->actionSocialShareAddMoreTwitter() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/nginx/domains/phcorner.net/public/admin.php at line 13
    Code:
    Server Error Log
    Error Info
    Abraham\TwitterOAuth\TwitterOAuthException: - library/bdSocialShare/Helper/twitteroauth/src/TwitterOAuth.php:141
    Generated By: Draft, 1 minute ago
    Stack Trace
    #0 /home/nginx/domains/domain.com/public/library/bdSocialShare/Helper/Twitter.php(127): Abraham\TwitterOAuth\TwitterOAuth->oauth('oauth/request_t...', Array)
    #1 /home/nginx/domains/domain.com/public/library/bdSocialShare/Helper/Twitter.php(32): TwitterOAuth->getRequestToken('https://www.phc...')
    #2 /home/nginx/domains/domain.com/public/library/bdSocialShare/XenForo/ControllerAdmin/Tools.php(148): bdSocialShare_Helper_Twitter::getAuthorizeUri('https://www.dom...')
    #3 /home/nginx/domains/domain.com/public/library/XenForo/FrontController.php(351): bdSocialShare_XenForo_ControllerAdmin_Tools->actionSocialShareAddMoreTwitter()
    #4 /home/nginx/domains/domain.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home/nginx/domains/domain.com/public/admin.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(70) "https://www.domain.com/admin.php?tools/social-share/add-more/twitter"
      ["_GET"] => array(1) {
        ["tools/social-share/add-more/twitter"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }
     
  12. RoldanLT

    RoldanLT Active Member

    Code:
    Server Error Log
    Error Info
    bdSocialShare_Exception_Interrupted: a:2:{i:0;s:83:"ronwelllocsin created "Swap pemkey". https://www.domain.com/t/thread.315057/";i:1;N;} - library/bdSocialShare/Model/Twitter.php:98
    Generated By: Unknown Account, 13 minutes ago
    Stack Trace
    #0 /library/bdSocialShare/Model/Publisher.php(152): bdSocialShare_Model_Twitter->publish('4900255483', Object(bdSocialShare_Shareable_Post), Array)
    #1 /library/bdSocialShare/Model/Publisher.php(27): bdSocialShare_Model_Publisher->twitterPublish('4900255483', Object(bdSocialShare_Shareable_Post), Array)
    #2 /library/bdSocialShare/Model/ShareQueue.php(70): bdSocialShare_Model_Publisher->publish('twitter', 'PHC_ONL,encrypt...', Object(bdSocialShare_Shareable_Post), Array)
    #3 /library/bdSocialShare/Model/ShareQueue.php(172): bdSocialShare_Model_ShareQueue->publish(Object(bdSocialShare_Shareable_Post), Array, false, Array)
    #4 /library/bdSocialShare/Deferred/ShareQueue.php(10): bdSocialShare_Model_ShareQueue->runQueue(8)
    #5 /library/XenForo/Model/Deferred.php(295): bdSocialShare_Deferred_ShareQueue->execute(Array, Array, 8, '')
    #6 /library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 8, '', false)
    #7 /library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
    #8 /deferred.php(23): XenForo_Model_Deferred->run(false)
    #9 {main}
    Request State
    array(3) {
      ["url"] => string(37) "https://www.domain.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(48) "/t/thread.315046/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
     
  13. xfrocks

    xfrocks XenForo rocks! Staff Member

    @RoldanLT probably a network error if that happens in a short time span. Do you still have it?
     
  14. RoldanLT

    RoldanLT Active Member

    Not happening now.
    Seems happen to me the whole day.
    and I think I reached twitter API limit.
     
Loading...