Edit/Add error

Discussion in '[bd] Widget Framework' started by Lorn, Aug 28, 2015.

  1. Lorn

    Lorn New Member

    #1 , Aug 28, 2015
    Last edited: Aug 28, 2015
    Hello. Today I downloaded your widget from https://xenforo.com/community/resources/bd-widget-framework.297/ and installed it on my forum. But when I tried to Edit or Add widget I get this error:

    [bd] Widget Framework

    [bd] Widget Framework People love widgets [FEATURES] 1. Add any widgets to any pages of XenForo or other add-ons. 2. Create new pages consists of widgets (built-in widgets or widgets from other...
    xenforo.com

    Server Error
    Invalid renderer 'WidgetFramework_WidgetRenderer_VisitorPanel' specified

    1. WidgetFramework_WidgetRenderer::create() in WidgetFramework/Core.php at line 677
    2. WidgetFramework_Core::getRenderer() in WidgetFramework/ControllerAdmin/Widget.php at line 351
    3. WidgetFramework_ControllerAdmin_Widget->_getRenderersList() in WidgetFramework/ControllerAdmin/Widget.php at line 95
    4. WidgetFramework_ControllerAdmin_Widget->_getResponseAddOrEdit() in WidgetFramework/ControllerAdmin/Widget.php at line 77
    5. WidgetFramework_ControllerAdmin_Widget->actionEdit() in XenForo/FrontController.php at line 347
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    7. XenForo_FrontController->run() in /home/u885808084/public_html/admin.php at line 13
    XenForo 1.4.3 version
    Please tell me what i'm doing wrong and how can I resolve this problem.
     
  2. Lorn

    Lorn New Member

    [​IMG]
     
    xfrocks likes this.
  3. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Sorry for your problem. How are you configuring the widget? A screenshot may be useful.
     
    1. Lorn

      Lorn New Member

      Lorn @xfrocks Screenshot of which exactly page do you need?
       
  4. Lorn

    Lorn New Member

    #5 Lorn, Aug 30, 2015
    Last edited: Aug 30, 2015
    I just upload files on forum and import addon-widget_framework.xml using XenForo add-on importer.
    All I can doing now is Enable/Disable widgets from Widget List. But if I try to configure one of them or add new I get error which I posted in first message.
     
  5. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Looks like you are having issue with one of the files of the add-on. Please try to download the zip file again from xenforo.com (make sure you have the latest version). First, uninstall the add-on from your site. Then upload the files + install it again.

    I can help you with installation if you send me the server information via conversation.
     
    Lorn likes this.
  6. Lorn

    Lorn New Member

    Okay. I'll reinstall add-on and try again.
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Lorn Hi there,

      Have you made any progress?
       
  7. Lorn

    Lorn New Member

    #9 Lorn, Sep 1, 2015
    Last edited: Sep 1, 2015
    Well... I've reinstalled add-on but it not working, then I change hosting for my forum and install it there and everything is Ok now. Thanks for very usefull add-on :)
     
    xfrocks likes this.
  8. Lorn

    Lorn New Member

    #10 Lorn, Sep 3, 2015
    Last edited: Sep 3, 2015
    Hello again) I have a question. How can I translate this phrases?

    [​IMG] [​IMG]
     
  9. Lorn

    Lorn New Member

    I found how to solve the problem.
     
Loading...