Unexpected error?

Discussion in '[bd] API' started by Allpar Dave, Aug 14, 2017.

  1. Allpar Dave

    Allpar Dave New Member

    I was using [bd] API for a year or two, and recently thought I'd update it because of the new features. However, as soon as I upload the files, I get:

    An unexpected error occurred. Please try again later.

    The log says:

    PHP Fatal error: Class 'bdApi_Template_Helper_Core' not found in /forums/library/bdApi/Listener.php on line 64

    Any thoughts? I'd like to reinstall.
     
    Tags:
  2. Allpar Dave

    Allpar Dave New Member

    Never mind. If anyone else runs into this, the solution is:

    1) Remove the library/bdApi folder so the forum works again
    2) Uncheck bd[API] in the add-on list
    /forums/admin.php?add-ons/
    3) Re-upload the library/bdApi folder
    4) Select update in the add-on list

    My fault for not deactivating before upgrading. sorry!
     
  3. Allpar Dave

    Allpar Dave New Member

    Also — thanks for making such fine software, at such a fine price. This really resolves a key need, as does the cache setup!
     
  4. xfrocks

    xfrocks XenForo rocks! Staff Member

    Hmm, it's weird. Probably you didn't upload all the files correctly? But yeah, general rule of thumb is to deactivate before upgrading 👍

    Thanks :p
     
Loading...