[bd] Cache 1.2.0b

Faster and faster.

  1. af123

    af123 New Member

    Since installing the addon I'm getting lots of file not found errors in my log for the amp logo. Looks like the path is not anchored. It definitely is on this forum so I wonder what's wrong with me installation.

    Code:
    2016/12/06 15:13:29 [error] 21687#1: *339124 open() ".../forum/threads/no-signal-or-weak-signal-message.2311/styles/default/bdCache/amp_logo.png" failed (2: No such file or directory), client: xx.xx.xx.xx, server: hummy.tv, request: "GET /forum/threads/no-signal-or-weak-signal-message.2311/styles/default/bdCache/amp_logo.png HTTP/1.1", host: "hummy.tv"
    
    Anyone have any ideas?

    Thanks.
     
    Last edited: Dec 6, 2016
  2. ehsan

    ehsan New Member

    Hi
    Just upload a logo here:
    styles/default/bdCache/amp_logo.png

    Or you may change it to your current logo in "bdcache_amp_header" template.
     
  3. ehsan

    ehsan New Member

    @xfrocks can you help me on this?
     
  4. xfrocks

    xfrocks XenForo rocks! Staff Member

    That variable is not available, I think you can check for "{$bdCache_isAmp}" instead.
     
    ehsan likes this.
  5. ehsan

    ehsan New Member

    Would you please make an example of that. for usage inside a template and remove some content from amp pages (for amp verification)
    Thanks
     
  6. xfrocks

    xfrocks XenForo rocks! Staff Member

    In another add-on of mine which render social buttons, it checks for amp mode and switch to use amp-social-share tag, something like this:

    Code:
    <xen:if is="{$bdCache_isAmp}">
        <amp-social-share type="facebook" data-url="{$url}" data-attribution="{$xenOptions.facebookAppId}">
        </amp-social-share>
    </xen:if>
    
     
  7. MFTeam

    MFTeam Webmaster

    After install i have to change anything in cloudflare?

    I have some option to test if everything is installed ok?
     
  8. MFTeam

    MFTeam Webmaster

    After install i have to change anything in cloudflare?
    M


    I have some option to test if everything is installed ok?
    Hi have the same problem.
    In that folder have a logo amp_logo.png, but the problem is path directory after i make a test show the path is wrong.

    After i submit this to the https://tools.pingdom.com
    https://www.mydomain.com/threads/thread.199625/?amp=199625

    Give-me one error :
    The following requests are returning 404/410 responses. Either fix the broken links, or remove the references to the non-existent resources.

    After i check i see this path error:
    https://www.mydomain.com/threads/thread.199625/styles/default/bdCache/amp_logo.png

    How to fix this?
     
  9. xfrocks

    xfrocks XenForo rocks! Staff Member

    The image path is built with imagePath style property. Do you have that setup properly in your style?
     
  10. MFTeam

    MFTeam Webmaster

    Yes my style is default xenforo.
    Code:
    https://www.mydomain.com/threads/thread.199625/styles/default/bdCache/amp_logo.png
    The problem is that path, the correct path is
    Code:
    https://www.mydomain.com/styles/default/bdCache/amp_logo.png
    Example image already default xenforo.
    Code:
    https://www.mydomain.com/styles/default/xenforo/gradients/form-button-white-25px.png
    Maybe is the /styles/default/xenforo/ ??

    That user have the same problem in the path.
    How to change this?
     
    Last edited: Feb 10, 2017
  11. MFTeam

    MFTeam Webmaster

    In the chrome console show this:

    Code:
    <amp-img src="styles/default/bdCache/amp_logo.png" title="Domain" width="600" height="60" layout="fixed" class="i-amphtml-element i-amphtml-layout-fixed i-amphtml-layout-size-defined i-amphtml-layout amp-notsupported" style="width: 600px; height: 60px;">
    <img title="Domain" class="i-amphtml-fill-content -amp-fill-content i-amphtml-replaced-content -amp-replaced-content -amp-ghost" src="styles/default/bdCache/amp_logo.png"></amp-img>
    
    
     
  12. MFTeam

    MFTeam Webmaster

    Ok, unsupported.

    Uninstalled!
     
  13. xfrocks

    xfrocks XenForo rocks! Staff Member

    The path is built in "bdcache_amp_header" template with:

    Code:
    @imagePath/bdCache/amp_logo.png
    We probably need to have a better way to build up the url.
     
Loading...