[bd] Image 2.2.2

Visual awareness increased.

  1. xfrocks

    xfrocks XenForo rocks! Staff Member

    Tags:
  2. anto74

    anto74 Member

    Hi @xfrocks
    i have one problem with this addon.
    I use [bd] Image: Threads Grid in my Home page ( Widget page) but randomly the images in widget not shows ( please see attached file)
    The images in threads have the same url structure and they shows ok
    The images ok is
    Code:
    https://macroforum.org/data/photos/o/0/22-1489582182-f6f225c4bdf6dd7c89d7991f29746f1a.jpg
    The image that not shows in widget is
    Code:
    https://macroforum.org/data/photos/o/0/21-1489582111-eff3fb6635f5c5e1fbc2076cad6f3979.jpg
    In Admin log error i have this error, related to image that not shows in widget

    Code:
    ErrorException: Fatal Error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: JPEG datastream contains no image - library/XenForo/Image/Gd.php:78
    Generato Da: Account Sconosciuto, 4 minuti fa
    Analisi dello Stack
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Stato Richiesta
    array(3) {
      ["url"] => string(214) "https://www.macroforum.org/bdImage/thumbnail.php?url=https%3A%2F%2Fmacroforum.org%2Fdata%2Fphotos%2Fo%2F0%2F21-1489582111-eff3fb6635f5c5e1fbc2076cad6f3979.jpg&size=145&mode=145&hash=47903f01d0badad169cbd3d24338fbf0"
      ["_GET"] => array(4) {
        ["url"] => string(89) "https://macroforum.org/data/photos/o/0/21-1489582111-eff3fb6635f5c5e1fbc2076cad6f3979.jpg"
        ["size"] => string(3) "145"
        ["mode"] => string(3) "145"
        ["hash"] => string(32) "47903f01d0badad169cbd3d24338fbf0"
      }
      ["_POST"] => array(0) {
      }
    }
    Where is the problem? I don't know why it happens randomly
    Thanks
    Antonio
     

    Attached Files:

  3. anto74

    anto74 Member

    Ok, i solved :)
    The problem was related to attachments max size set too small in admin panel :)
    Now it's ok
    Antonio
     
    xfrocks likes this.
  4. anto74

    anto74 Member

    Hi @xfrocks
    i'm using [bd] Image Thread Grid to shows photos embedded in New threads, but i would to shows also photo embedded in New threads created only by user that i follow.
    It's possible make this modification if i paid?
    Thanks
    Antonio
     
    Last edited: Mar 16, 2017
  5. anto74

    anto74 Member

    Hello @xfrocks
    i have little problem.
    I added bd Image sidebar widget in thread view template to shows other photos=threads uncommented by logged user.
    example: https://macroforum.org/threads/empusa-pennata-thunberg-1815-_2.101/

    I want shows only photos=threads uncommented by logged user: if this user commented photo=thread the thread not shows in widget...
    How can i make this?
    Thanks
    Antonio
     
    Last edited: Apr 10, 2017
  6. Arms

    Arms New Member

  7. xfrocks

    xfrocks XenForo rocks! Staff Member

    They are quite different in nature and can be used together if you need both of their features. The add-on can pick an image automatically, you can change that in the options page. For existing threads, you can run the rebuild tool to pick up thread images.
     
    Arms likes this.
  8. Arms

    Arms New Member

    Still can't get this to work as I want.

    upload_2017-7-15_17-39-59.png


    If no image is added, its using the avatar? does it not use the fallback image?

    And it wont automatically use a hotlinked image?
     
  9. Arms

    Arms New Member

    Last edited: Jul 21, 2017
  10. Arms

    Arms New Member

    Sorry, For refrence, im using version 2.2.1 from github
     
  11. sami simo

    sami simo Webmaster

    Hi Arms, do you still have this same issue, because Im thinking to upgrade to the latest version from github.
     
  12. Arms

    Arms New Member

    I moved back to 1.22. There were a few things i couldn't get to work.

    Images were not showing on a forum that i had an rss feed in. i had to go in and edit before image would show.(works in 1.2.2)
    Wanted the fallback image to show, but was showing avatar.
    And couldn't use <img src="{xen:helper bdImage_thumbnail, $thread.bdimage_image, 240, sh}" alt="{$forum.title}" class="center" /> (works in 1.2.2)
     
    sami simo likes this.
  13. sami simo

    sami simo Webmaster

    I agree, the last version is awsome. however it doesnt extract image automaticaly like the previous one, so I will continue with the old one.
     
  14. Arms

    Arms New Member

  15. xfrocks

    xfrocks XenForo rocks! Staff Member

    Did you enable the option to extract image? The github version does not change the extraction code so it should work as before, make sure the option is on.
     
  16. xfrocks

    xfrocks XenForo rocks! Staff Member

    Ah, we have removed support for xen:helper. In light of your usage, we may add it back then.

    Also, can you describe the issue with that forum with rss feed? It was not really clear to me what is the issue.
     
  17. Arms

    Arms New Member


    Thanks Xfrocks.

    I've reverted back to 1.2.2, to be able to use the helper. It's very convenient to be able to pull the image for the thread into a widget on the thread (using template renderer.).
    If there was a widget for single threads, i could use that.

    Regards, auto extraction of image, I had the option set to extract, but if i didn't choose an image, it would only show avatar. As i had an rss feed, it wouldn't select any images.

    Example:


    upload_2017-8-1_11-43-45.png
     
  18. sami simo

    sami simo Webmaster

    The option is enabled in my test forum:
    11.JPG
    but it display no thumbnail until I edit the thread here and choose the image:
    2.JPG

    I should say that there was an error during installation:
    maybe the extraction is not working because of this.
     
  19. xfrocks

    xfrocks XenForo rocks! Staff Member

    @Arms, we have released a new 2.2.1 here at https://xfrocks.com/resources/bd-image.32/, please try that version. It should have the helper back.

    @sami simo, did you enable the option to use all attachments to pick a thumbnail? Normally it will only pick one inserted into the post.
     
    RoldanLT likes this.
Loading...