[bd] Push Notification 2.1.1b

Mobile push notification with Pushover and Pushbullet

  1. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    xfrocks submitted a new resource:

    [bd] Pushover Integration - Mobile push notification for alerts.

    Read more about this resource...
     
    MattW, john_the_tester and Arms like this.
  2. john_the_tester

    john_the_tester New Member
    Partner

    xfrocks likes this.
  3. Daniel-Sp

    Daniel-Sp New Member

    Awesome !
     
  4. MattW

    MattW Member

    Getting lots of these in the error log

    Server Error Log
    Error Info
    ErrorException: Fatal Error: Unsupported operand types - library/bdPushover/XenForo/DataWriter/Alert.php:15
    Generated By: Unknown Account, 8 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(32) "https://z22se.co.uk/deferred.php"

    Z22SE.co.uk

    Z22SE.co.uk Site dedicated to the Z22SE Z22YH Z20NET engines
    z22se.co.uk

    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(67) "/threads/which-parts-can-cause-performance-issues-flat-spots.19398/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  5. MattW

    MattW Member

    This is the function causing the problem

    PHP:
        protected function _postSaveAfterTransaction()
        {
            
    $assoc $this->_bdPushover_getAlertedUserPushoverAssoc();
            if (!empty(
    $assoc))
            {
                
    $sender $this->_bdPushover_getSender();

                
    bdPushover_Helper_Alert::enqueue($this->getMergedData() + $sender$assoc);
            }
        }
     
  6. xfrocks

    xfrocks XenForo rocks!
    Staff Member

  7. mouth

    mouth New Member

  8. MattW

    MattW Member

    Does this fix the errors? I'm getting no push alerts, and an error each time deferred is called
     
    1. MattW

      MattW Member

      MattW @MattW Nope, error still there and no alerts

      Code:
      Server Error Log
      Error Info
      ErrorException: Fatal Error: Unsupported operand types - library/bdPushover/XenForo/DataWriter/Alert.php:15
      Generated By: Unknown Account, 2 minutes ago
      Stack Trace
      #0 [internal function]: XenForo_Application::handleFatalError()
      #1 {main}
      Request State
      array(3) {
        ["url"] => string(32) "https://z22se.co.uk/deferred.php"
        ["_GET"] => array(0) {
        }
        ["_POST"] => array(4) {
          ["_xfRequestUri"] => string(10) "/admin.php"
          ["_xfNoRedirect"] => string(1) "1"
          ["_xfToken"] => string(8) "********"
          ["_xfResponseType"] => string(4) "json"
        }
      }
      I've turned Delayed Push off to see if that helps.
       
  9. MattW

    MattW Member

    No difference. Got hundreds of these errors now :(
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW Looks like a conflict. Do you have idea of any add-on that deals with alerts?
       
    2. MattW

      MattW Member

    3. xfrocks

      xfrocks XenForo rocks!
      Staff Member

  10. MattW

    MattW Member

    Disabled, and didn't re-enable the delay option.
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW And...?
       
  11. MattW

    MattW Member

    Nope, still got another error come though with that disabled.
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW How many add-ons to you have? Is it possible to disable all of them except for this one add-on to find the conflict?
       
  12. MattW

    MattW Member

    Have disabled Live Update first.
     
  13. MattW

    MattW Member

    Not that one either. Looks like I might have to start disabling them all :(
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW Sorry :(
       
  14. MattW

    MattW Member

    i think it's something with a cron running every 10 minutes, so i'm waiting for it to happen again
     
  15. MattW

    MattW Member

    It's generating the error each time the Feeder cron is ran (every 10 minutes)

    upload_2014-4-2_18-8-25.png
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW Oh, so you got the error when the cron entry run not from receiving an alert? Btw, have you ever received a push message since you set it up?
       
    2. MattW

      MattW Member

      MattW @xfrocks Yes, it would appear that way. I didn't realise it before, as I didn't see the pattern to the errors

      upload_2014-4-2_18-45-19.png

      They are every 10 minutes or so, and the only thing running from cron every 10 minutes is the feeder cron.

      I am receiving push alerts as well.
       
    3. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW Okie, so it looks like the Feeder cron send out alerts from guests... You have any idea why that happens? Probably some configuration/add-on?
       
  16. MattW

    MattW Member

    I'm importing feeds and having the feeds posted as guest users.
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @MattW Then you watch the forum where it posts thread so you receive alerts from guest? How does it normally show up?
       
    2. MattW

      MattW Member

      MattW @xfrocks Yes, so I watch a hidden forum on my site for new threads, which are created via the feeder

      upload_2014-4-2_18-50-40.png


      Feed settings

      upload_2014-4-2_18-51-4.png

      and a new thread

      upload_2014-4-2_18-51-23.png
       
  17. MattW

    MattW Member

    I've disabled all the feeds, so will see what happens.
     
  18. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Interesting, I haven't guard for that. How is the guest show up in alert list btw? "Linode" with guest avatar?
     
    1. MattW

      MattW Member

      MattW @xfrocks Yes:
      upload_2014-4-2_18-55-14.png
       
  19. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Thank you @MattW for bearing with me. Update is coming ;)
     
    MattW likes this.
Loading...