[bd] Reroute [Paid] 1.0.6

Take extra care of those shiny URLs.

  1. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    xfrocks submitted a new resource:

    [bd] Reroute - Take extra care of those shiny URLs.

    Read more about this resource...
     
  2. RoldanLT

    RoldanLT Active Member

    Do you have a demo for custom sub domain?
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @RoldanLT I don't have a spare XenForo license so I can't show you it live. Sorry.
       
      RoldanLT likes this.
      1
  3. Mike

    Mike New Member

    What does "skip as parent" do?
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Mike Skip parent will exclude the route when building a node / thread url. For example you have 1 category (reroute as parent), 1 forum (reroute as main). Normally, link to threads will be parent/main/threads/... but if you skip as parent in the category, it will be main/threads/... only.
       
  4. Mike

    Mike New Member

    Getting this error after changing members reroute

    Error Info
    ErrorException: Undefined index: path - library/bdReroute/Overridden/Link.php:16
    Generated By: Unknown Account, A moment ago
    Stack Trace
    #0 /home/hockey/public_html/library/bdReroute/Overridden/Link.php(16): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/hockey/pu...', 16, Array)
    #1 /home/hockey/public_html/library/bdReroute/Domain.php(100): bdReroute_Overridden_Link::modifyRequestPaths()
    #2 /home/hockey/public_html/library/bdReroute/Listener.php(75): bdReroute_Domain::setupDomain('members.hockeyf...')
    #3 [internal function]: bdReroute_Listener::init_dependencies(Object(XenForo_Dependencies_Public), Array)
    #4 /home/hockey/public_html/library/XenForo/CodeEvent.php(90): call_user_func_array(Array, Array)
    #5 /home/hockey/public_html/library/XenForo/Dependencies/Abstract.php(214): XenForo_CodeEvent::fire('init_dependenci...', Array)
    #6 /home/hockey/public_html/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
    #7 /home/hockey/public_html/index.php(13): XenForo_FrontController->run()
    #8 {main}


    Also get the error going to https://members.hockeyforu.ms/admin.1/
     
  5. Mike

    Mike New Member

    and the error above? :D
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Mike I have just released v1.0.3d, try upgrading to it maybe? ;)
       
  6. Mike

    Mike New Member

    okey dokey! Will do it now and report back in a few minutes..
     
  7. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Actually it is a different message. Please check your board url option in AdminCP, what is it currently?
     
  8. Mike

    Mike New Member

    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

  9. Mike

    Mike New Member

    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

  10. Mike

    Mike New Member

    Please add :) We are best friends after all, right? :D
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Mike Haha, I will see. Have you got it working now btw?
       
  11. Mike

    Mike New Member

    Sec, uploading it now.
     
  12. Mike

    Mike New Member

    Yeap, working!
     
    xfrocks likes this.
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Mike Awesome.
       
      Mike likes this.
      1
  13. moshbit

    moshbit New Member

    i'm having an issue where category node urls aren't getting re-written. for example:

    'destinations by region' has been set to 'destinations' in the route field. it displays as:

    https://squattheplanet.com/categories/destinations-by-region.32/

    Destinations by Region | Squat the Planet

    Here you can research travel destinations organized by regions of the globe.
    squattheplanet.com


    the sub-forum 'north america' has been set to 'north-america' in the custom route field. it displays as:

    https://squattheplanet.com/categories/north-america.200/

    North America | Squat the Planet

    Here you'll find discussions of travel destinations found inside the North American continent. These countries include Canada, The United States of of America, Mexico and Central America.
    squattheplanet.com


    but for some reason the sub forum of north america "canada" displays as so (after setting it as 'canada' in the custom route field):

    https://squattheplanet.com/destinations/north-america/canada/

    Canada | Squat the Planet

    Here you'll find discussions on travel destinations within the great northern region of North America.
    squattheplanet.com


    also, united states and mexico are sibling nodes and display correctly as well:

    https://squattheplanet.com/destinations/north-america/united-states/

    United States | Squat the Planet

    The United States of America has many travel destinations available across a breadth of different kinds of climates and cultures. Join one of our many discussions with other travelers here.
    squattheplanet.com

    https://squattheplanet.com/destinations/north-america/mexico/

    Mexico | Squat the Planet

    Mexico is a large country with a fascinating culture and many places worth traveling to see. Share your previous travels or discuss future plans in this region with other nomads.
    squattheplanet.com


    so i'm not sure what's wrong?
     
    1. moshbit

      moshbit New Member

      moshbit @moshbit while the previous server errors have been fixed with the latest update, the issue with categories not being re-written correctly is still an issue. are you planning on fixing this? it's been over two months.
       
  14. moshbit

    moshbit New Member

    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @moshbit This sounds like a conflict issue. Can you disable some add-on that you think may cause the problem?
       
  15. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    You are right, I don't see any potential conflict there. Please start a conversation with me with your site info, I will have to login and check myself. Sorry for the inconvenience.
     
  16. moshbit

    moshbit New Member

    no worries, i PM'ed you my info.

    on a side note, bringing vanity name urls like squattheplanet.com/username would be a pretty killer feature. i know there's another plugin that does this, but it would be nice to have it wrapped up in this one so there's no potential conflicts.
     
  17. moshbit

    moshbit New Member

    i've got a few hundred routing errors in my server log now as well. i sent you a PM about it but i haven't heard back from you. any word on this? they mostly look like this:

    most of them seem to be failures to reroute urls by this plugin:

     
  18. moshbit

    moshbit New Member

    errr... maybe a screen shot would be better:

    broke.png
     
Loading...