Thread is.New info cached somewhere

Discussion in '[bd] Widget Framework' started by Sebouley, May 2, 2015.

  1. Sebouley

    Sebouley New Member

    Hello Xfrocks,

    I'm using WF 2.5.9 in the latest Xenforo.
    I'm using last replies widgets with the "isnew" information added (with bold if unread)

    It works well if I actually click the links and go to the thread, they are marked as read in the widget as well

    However, everything breaks if I click on "mark all forums read"

    First of all, the "read/unread" status in the widget does not change at all, but more than that, clicking on an unread thread never marks it as read.

    I've tried disabling caching in the widget, in threads.php, I disabled my Xcache, nothing helps

    It just seems WF has some "read/unread" cache of it's own, that does not get updated once you click "mark all as read" and this information seems to be kept forever/a long time

    Any help appreciated !
     
  2. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Hi there,

    I couldn't reproduce this issue on the Dev site so I think it may be a conflict with some other add-on. Can you give me list of installed add-on? You may post it here or via conversation.

    Thank you and sorry for your problem.
     
  3. Sebouley

    Sebouley New Member

    I'll do more than that and set-up a test forum and give you admin access. I'm 90% positive this is a bug in WF; because I tried disabling every mod, disabling xcache, and the problem remains.
    I would hapilly give you admin xs on the affected forum but it's a live env. and it would be difficult for you to make tests.
     
    xfrocks likes this.
  4. Sebouley

    Sebouley New Member

    @xfrocks don't forget about this "beta softwar" you were going to send me... thanks !
     
  5. xfrocks

    xfrocks XenForo rocks!
    Staff Member

  6. Sebouley

    Sebouley New Member

    Hello,
    I'm afraid the same bug still exist even with this beta : if you mark all as read, widgets with "isnew" info are not marked as read.
    You can find a demo on the same website you have access to (see my previous private message)

    Could you have another look ?
     
  7. xfrocks

    xfrocks XenForo rocks!
    Staff Member

    Hi there,

    May I have FTP access to the site please?
     
  8. Sebouley

    Sebouley New Member

    #8 Sebouley, May 16, 2015
    Last edited: May 16, 2015
    Hello
    I've set up a test access for you on a site with the bug.

    I've now reinstalled a STOCK xf1.4.7, the only thing that's there is bd widget framework, you create a widget on the forumlist, with latets replies, you make another user make a reply, you mark all as read ; it's not marked as read in the widget...
    It's not a bug at my place, it's a bug you can easily reproduce...

    I'll send the login info for that test copy, in private
     
    1. xfrocks

      xfrocks XenForo rocks!
      Staff Member

      xfrocks @Sebouley Thank you.
       
Loading...