[bd] Reroute [Paid] 1.0.6

Take extra care of those shiny URLs.

  1. moshbit

    moshbit New Member

    i'm having an issue where category node urls aren't getting re-written. for example:

    'destinations by region' has been set to 'destinations' in the route field. it displays as:

    https://squattheplanet.com/categories/destinations-by-region.32/

    Destinations by Region | Squat the Planet

    Here you can research destinations organized by region of the globe.
    squattheplanet.com


    the sub-forum 'north america' has been set to 'north-america' in the custom route field. it displays as:

    https://squattheplanet.com/categories/north-america.200/

    North America | Squat the Planet

    This area of the forum is comprised of the countries making up the North American continent. These countries include Canada, The United States of of America, Mexico and those in Central America.
    squattheplanet.com


    but for some reason the sub forum of north america "canada" displays as so (after setting it as 'canada' in the custom route field):

    https://squattheplanet.com/destinations/north-america/canada/

    Canada

    Here you'll find discussions on the great northern region of North America.
    squattheplanet.com


    also, united states and mexico are sibling nodes and display correctly as well:

    https://squattheplanet.com/destinations/north-america/united-states/

    United States

    The USA consists of 50 states, and is a big place with a lot to see. Find out the best places to go and give your own advice on your favorite cities.
    squattheplanet.com

    https://squattheplanet.com/destinations/north-america/mexico/

    Mexico

    Mexico is an interesting and sometimes lawless country with a interesting culture. Find out what others have to say about it here.
    squattheplanet.com


    so i'm not sure what's wrong?
     
  2. moshbit

    moshbit New Member

  3. xfrocks

    xfrocks XenForo rocks! Staff Member

    This sounds like a conflict issue. Can you disable some add-on that you think may cause the problem?
     
  4. moshbit

    moshbit New Member

  5. xfrocks

    xfrocks XenForo rocks! Staff Member

    You are right, I don't see any potential conflict there. Please start a conversation with me with your site info, I will have to login and check myself. Sorry for the inconvenience.
     
  6. moshbit

    moshbit New Member

    no worries, i PM'ed you my info.

    on a side note, bringing vanity name urls like squattheplanet.com/username would be a pretty killer feature. i know there's another plugin that does this, but it would be nice to have it wrapped up in this one so there's no potential conflicts.
     
  7. moshbit

    moshbit New Member

    i've got a few hundred routing errors in my server log now as well. i sent you a PM about it but i haven't heard back from you. any word on this? they mostly look like this:

    most of them seem to be failures to reroute urls by this plugin:

     
  8. moshbit

    moshbit New Member

    errr... maybe a screen shot would be better:

    broke.png
     
  9. moshbit

    moshbit New Member

    so... it's been almost two weeks and you haven't responded to my pm's or message here... is this still supported?
     
  10. xfrocks

    xfrocks XenForo rocks! Staff Member

    It is still supported. Sorry for the late response though.

    I have received a few reports regarding this and they are all about url with a missing slash at the end of it. Normally XenForo generates thread url (like this thread's) with a slash https://xfrocks.com/other/threads/bd-reroute-paid.316/ but for some unknown reason, the url without slash is being accessed and triggered a wrong routing from the add-on. A fix will be available soon.

    [bd] Reroute [Paid]

    xfrocks submitted a new resource: [bd] Reroute - Take extra care of those shiny URLs. [bd] Reroute Take extra care of those shiny URLs. [FEATURES]...
    xfrocks.com
     
  11. moshbit

    moshbit New Member

    ok. thank you, looking forward to the update.
     
  12. xfrocks

    xfrocks XenForo rocks! Staff Member

  13. xfrocks

    xfrocks XenForo rocks! Staff Member

    v1.0.4 is now available. Please update and see the error still occurs.
     
  14. xfrocks

    xfrocks XenForo rocks! Staff Member

    Have you tried the update, how did it go?
     
  15. Anton

    Anton New Member

    Hi i bought reroute addon and i cant figure out how to set up what we need

    I managed to set up this :

    hen thread is created Url shows this way
    www.sitename.com/category/thread/threadname

    GBut we need get rid of work THREAD , so it looks like as this:
    ex:
    www.sitename.com/categoryname/threadname

    plz help

    Custom Route:
    In category i put categoryname
    In options reroute set to -1
     
  16. xfrocks

    xfrocks XenForo rocks! Staff Member

    You cannot remove "threads".
     
  17. Anton

    Anton New Member

    Last edited: Jan 3, 2015
  18. xfrocks

    xfrocks XenForo rocks! Staff Member

    You can do that with XenForo route filters but it will be the same across all forums. If you need it to be different for each forum, it may be possible though.
     
  19. Anton

    Anton New Member

    thnx will look forward to it
     
  20. moshbit

    moshbit New Member

    while the previous server errors have been fixed with the latest update, the issue with categories not being re-written correctly is still an issue. are you planning on fixing this? it's been over two months.
     
Loading...